Duplicated articles - automatic update to all sites

Completed

Comments

6 comments

  • Official comment
    Avatar
    Trevor DeVore

    Will - In ScreenSteps if you duplicate an article then a copy is created that is not kept in sync with the original article. If you reference an article then an alias is created and updating either the original or the alias will update the article everywhere. Take a look at these two articles that discuss how aliases work:

    https://help.screensteps.com/m/managing/l/548436-what-are-article-aliases

    https://help.screensteps.com/m/managing/l/182822-how-to-see-where-an-article-is-being-used-in-your-account

    Comment actions Permalink
  • Avatar
    Will Young

    Hi Trevor,

    I do understand the difference between the duplicates and the aliases. My question refers to pushing the article to an external service such as Zendesk. When I update a referenced article, the alias is automatically updated in Screensteps, but when I publish a referenced article to Zendesk, the alias is not automatically published as well. Therefore the two referenced articles in Zendesk, which should be identical, are different.

    It's not a huge deal - I can open the alias from the article I changed and push that to Zendesk easily enough, but it would be nice to have the option to automate it.

    0
    Comment actions Permalink
  • Avatar
    Trevor DeVore

    Ah, Zendesk. That is probably a bug on our end. I'll have someone look into it.

    0
    Comment actions Permalink
  • Avatar
    Will Young

    Great, thanks!

    0
    Comment actions Permalink
  • Avatar
    Trevor DeVore

    This bug has been fixed Will. Your aliases should update in Zendesk as well now.

    0
    Comment actions Permalink
  • Avatar
    Will Young

    Hi Trevor,

    Thanks - I have tested this and it works as expected - pushing either one of the aliases updates the other.

    However, there is still a small issue - if you click the Save & Publish button, everything is fine, but if you use any of the 'Push update to Zendesk HC' options you get a red error banner with 'There was a problem: [object Object]'. Right now I assume that this is an error with the message, as the updates are pushed live, but the feedback is confusing. 

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk